Nvidia, Lion ed i problemi con World of Warcraft

Nvidia su Mac si sa, non è proprio famosa per il suo supporto e non è nuova a problemi sia hardware (vedi problemi alla scheda logica nei Macbook Pro Late 2008) che software. Con World of Warcraft, ad esempio, i problemi risalgono già dalle scorse versioni di OSX, con crash improvvisi, mentre con Lion, i problemi si sono ripresentati con la più fastidiosa delle sue forme, gli artefatti (glitches).

Il problema sembra sia dovuto alla versione di OpenGL che su Lion è la 3.2, e quindi i driver Nvidia sarebbero obsoleti. Andiamo al sodo ed eccovi di seguito il procedimento rapido ed indolore per risolvere l'annoiante problema.

Aprite con un editor di testo il file config.wtf, che trovate all'interno della cartella WTF nella directory di World of Warcraft, controllate se è presente la voce SET gxAPI. Se è già presente cambiate il valore da OpenGL a GLL, se invece non è presente come nel mio caso, aggiungete l'intera riga, ovvero SET gxAPI "GLL".

Fatto ciò salvate ed aprite il vostro gioco, finalmente senza più problemi grafici.

AGGIORNAMENTO: per evitare che il gioco, una volta aperto, modifichi di nuovo la stringa rimettendo OpenGL come valore, cliccate sul file Config.wtf col tasto destro- Ottieni Informazioni, ed in basso settate i permessi in sola lettura.

Autore: Simone Tambasco

Geek inside (pure troppo)

Condividi su
  • alcap

    Provato, ma purtroppo in automatico mi rimette il file “openGL”
    quindi a me non funziona

    • Ciao, con che Mac hai provato? E che scheda? E che client? Io ho provato su un mb pro con nvidia 8600 e con Wrath of the Lich King

  • Matteo

    Anche a me rimette il file “openGL” e indi per cui non funziona nemmeno a me, devo bloccare in qualche modo quel file?

    • molto strano, sul mio macbook pro non ha rimesso nulla 😐

    • ciao, a seguito di un reinstall, la stessa cosa l’ha fatta anche a me, ho risolto settando i permessi in sola lettura sul file Config.wtf (ho aggiornato il post)

  • Paolo

    Io ho un Macbook pro 17″ 2.8ghz late 2009 con Lion.
    Ho provato la scheda 9600 gt e il risultato è stato vedere le immagini deformarsi in modo spaventoso una volta loggato…pensando ad un errore sto reinstallando tutto…